Frequently Asked Questions

Why do I get an 'update error' when trying to update one of your apps?
Last Updated 2 years ago

If you try to update one of our direct apps and this error dialog appears…

Update Error! An error occurred while extracting the archive. Please try again later.

…this is caused by trying to update an older version of one of our apps in macOS Sierra or later. In a nutshell, there was a problem with the version of the Sparkle update framework in our older apps: It failed in macOS Sierra. To fix this, we had to update Sparkle in our apps (which we did). But if you didn't update to the Sparkle-fixed version of the app before you updated to macOS Sierra, you'll see the above error message.

The solution is easy: You need to download the full app from our web site. You will only need to do this one time, as you'll now have the updated Sparkle framework, and future updates will work fine. Just replace your old app with the new app, and you'll be set—you won't lose any settings or customizations, as those are stored elsewhere.

Please Wait!

Please wait... it will take a second!